eXeLab
eXeL@B ВИДЕОКУРС !

ВИДЕОКУРС ВЗЛОМ
выпущен 12 ноября!


УЗНАТЬ БОЛЬШЕ >>
Домой | Статьи | RAR-cтатьи | FAQ | Форум | Скачать | Видеокурс
Новичку | Ссылки | Программирование | Интервью | Архив | Связь

Русский / Russian English / Английский

Сейчас на форуме: (+3 невидимых)
 · Начало · Статистика · Регистрация · Поиск · ПРАВИЛА ФОРУМА · Язык · RSS · SVN ·

 eXeL@B —› Софт, инструменты —› GammaRay
Посл.ответ Сообщение


Ранг: 238.8 (наставник)
Статус: Участник
CyberHunter

Создано: 24 мая 2015 07:13 New!
Цитата · Личное сообщение · #1

Просьба скомпильте кому не сложно
http://habrahabr.ru/company/infopulse/blog/258411/
https://github.com/KDAB/GammaRay

Ранг: 505.2 (!)
Статус: Модератор

Создано: 24 мая 2015 18:00 New!
Цитата · Личное сообщение · #2

собрал такую версию (мастер с гитхаба)
http://prntscr.com/78tezm
https://www.sendspace.com/file/o48hc5

| Сообщение посчитали полезным: Flint



Ранг: 238.8 (наставник)
Статус: Участник
CyberHunter

Создано: 24 мая 2015 23:50 New!
Цитата · Личное сообщение · #3

Дебаг версия получилась, не хватает библиотек.
Первый мессадж:
Запуск программы невозможен, так как на компьютере отсутствует QtCored4.dll. Попробуйте переустановить программу.


Ранг: 210.0 (наставник)
Статус: Участник
X-Literator

Создано: 25 мая 2015 01:04 · Поправил: 25 мая 2015 01:06 Crawler New!
Цитата · Личное сообщение · #4

Надо просто статик версию скомпилить

* с флагом MT

Ранг: 4.9 (гость)
Статус: Участник

Создано: 25 мая 2015 14:58 New!
Цитата · Личное сообщение · #5

Тоже заинтересовало это приложение. Если не трудно, положите в архив недостающие библиотеки QtCore4.dll, QtCored4.dll, QtGui4.dll, QtGuid4.dll, QtNetwork4.dll, QtNetworkd4.dll. Их можно скопировать из папки с установленной Qt.

Ранг: 505.2 (!)
Статус: Модератор

Создано: 26 мая 2015 01:26 New!
Цитата · Личное сообщение · #6

Flint пишет:
Дебаг версия получилась, не хватает библиотек.

Сделал релизную
внутри 3 release QT dll

https://www.sendspace.com/file/osbwgt

| Сообщение посчитали полезным: Gaal, Flint, icerix


Ранг: 4.9 (гость)
Статус: Участник

Создано: 26 мая 2015 10:28 New!
Цитата · Личное сообщение · #7

sendersu, к сожалению не получается ни открыть файл, ни подсоединиться к процессу. Всегда одно и тоже сообщение: "No probe found for ABI qt4.8-MSVC-release-i686".

Поиск по этой ошибке на гитхабе дал ответ: "Mismatching Qt version is one possibility, on Windows you also need matching compiler and debug/release mode." Но совершенно не ясно, как устранить проблему.

sendersu, какая версия Qt у вас установлена? Судя по файла, вроде как 4.8, но какая конкретно (третья цифра билда).

Да, еще одной библиотеки не хватает — QTest4.dll.

Ранг: 505.2 (!)
Статус: Модератор

Создано: 26 мая 2015 21:04 · Поправил: 26 мая 2015 21:15 sendersu New!
Цитата · Личное сообщение · #8

QT 4.8.4
планирую на 4.8.6 переехать (qt-opensource-windows-x86-vs2010-4.8.6.exe)
ошибка идет отсюда
http://prntscr.com/79oaym
надо разбираться
upd: http://prntscr.com/79oj38 прога ищет дллку, находит релизную, дебажной нету, ошибка верная
QTest4.dll у себя не нашел

Ранг: 4.9 (гость)
Статус: Участник

Создано: 27 мая 2015 00:42 New!
Цитата · Личное сообщение · #9

sendersu пишет:
QTest4.dll у себя не нашел

Прошу прощения, я ошибся. Правильно будет — QtTest4.dll. Это я по ЕХЕ-шникам клацал в надежде хоть что-то запустить, и на файле probeabitest.exe выдало, что не найдена эта библиотека.

Ранг: 505.2 (!)
Статус: Модератор

Создано: 27 мая 2015 07:41 New!
Цитата · Личное сообщение · #10

Вот все длл из QT484/release
https://www.sendspace.com/file/noomxw

Ранг: 4.9 (гость)
Статус: Участник

Создано: 27 мая 2015 12:36 New!
Цитата · Личное сообщение · #11

sendersu, спасибо, но у меня результат все тот же: No probes found - GammaRay no functional.

Ранг: 42.9 (посетитель)
Статус: Участник

Создано: 27 мая 2015 13:03 · Поправил: 27 мая 2015 13:06 Alf New!
Цитата · Личное сообщение · #12

Gaal пишет:
Mismatching Qt version is one possibility

сабж должен быть скомпилирован с той же версией Qt что и исследуемая программа

Gaal пишет:
но у меня результат все тот же: No probes found - GammaRay no functional.

папка plugins должна быть на уровень выше, а не в bin

ЗЫ сабж еще чего-то ищет в папке d:\dev\Libs\Qt\4.8.4\plugins\

| Сообщение посчитали полезным: Gaal


Ранг: 15.8 (новичок)
Статус: Участник

Создано: 27 мая 2015 18:03 New!
Цитата · Личное сообщение · #13

Alf пишет:
сабж должен быть скомпилирован с той же версией Qt что и исследуемая программа

т.е. если сабж на qt5 x64, то и гаммарей тоже?
я вижу, что только qt4 поддержана или ошибаюсь?!

Ранг: 505.2 (!)
Статус: Модератор

Создано: 27 мая 2015 19:35 New!
Цитата · Личное сообщение · #14

Alf пишет:
ЗЫ сабж еще чего-то ищет в папке d:\dev\Libs\Qt\4.8.4\plugins\

QT484 plugins
https://www.sendspace.com/file/m5btfc

Gaal пишет:
спасибо, но у меня результат все тот же: No probes found - GammaRay no functional.


если не охота париться- тяните QT484 installer

если охота поиграццо - procmon и ищем чего не хватает

Ранг: 4.9 (гость)
Статус: Участник

Создано: 27 мая 2015 23:19 New!
Цитата · Личное сообщение · #15

Alf, спасибо за подсказку. То что доктор прописал. Наконец-то удалось посмотреть на программу изнутри. По правде сказать ожидал большего. Открывает простенькие программы из разряда примеров, поставляемых с Qt, а на серьезных программах молча закрывается или сообщает об ошибке.

sendersu, спасибо вам, что откликнулись и уделили время на компиляцию программы.

Ранг: 33.9 (посетитель)
Статус: Участник

Создано: 8 июля 2015 20:23 New!
Цитата · Личное сообщение · #16

кому не трудно, залейте еще раз на файловую помойку, линки протухли.
 eXeL@B —› Софт, инструменты —› GammaRay

Оригинальный DVD-ROM: eXeL@B DVD !

Вы находитесь на форуме сайта EXELAB.RU
Проект ReactOS