Русский / Russian English / Английский

Сейчас на форуме: Vicshann (+1 невидимый пользователь)
 · Начало · Статистика · Регистрация · Поиск · ПРАВИЛА ФОРУМА · Язык · RSS ·

 eXeL@B —› Софт, инструменты —› Установка Kylix 3 Ent
Посл.ответ Сообщение

Ранг: 122.2 (ветеран)
Статус: Участник

Создано: 22 мая 2007 13:07 New!
Цитата · Личное сообщение · #1

Люди. понимаю что немного не в тему, но может кто знает.

Подскажите на какой линукс можно без проблем Kylix 3 поставить.



Ранг: 11.1 (новичок)
Статус: Участник

Создано: 22 мая 2007 13:24 New!
Цитата · Личное сообщение · #2

На очень старый. Любой линуксоид тебе скажкт - что делать это нестоит. Он устарел и неподдерживается.
Имеешь реальные шансы получить или нерабочую среду или непортабельные приложения.



Ранг: 122.2 (ветеран)
Статус: Участник

Создано: 22 мая 2007 13:29 New!
Цитата · Личное сообщение · #3

Я пробовал на Ubuntu 4.10 под VMware 6. Не получилось. Библиотека одна (а может и не одна) оказалась не той версии.
Я не по своей воле. Начальниксказал, что надо установить.



Ранг: 210.5 (наставник)
Статус: Участник

Создано: 22 мая 2007 13:33 New!
Цитата · Личное сообщение · #4

egorovshura

Ну попробуй Федору тех времён, или может Mandrake 10



Ранг: 11.1 (новичок)
Статус: Участник

Создано: 22 мая 2007 14:03 New!
Цитата · Личное сообщение · #5

egorovshura
На рэдхат вроде вставал 7.1 или 8. Не помню точно.




Ранг: 2014.5 (!!!!)
Статус: Модератор
retired

Создано: 22 мая 2007 15:04 New!
Цитата · Личное сообщение · #6

В своё время нормально встал на 9 Мандряк, точно помню. Только вот как ставил, уже не помню, ибо давно было.



Ранг: 20.8 (новичок)
Статус: Участник

Создано: 22 мая 2007 15:29 · Поправил: Player New!
Цитата · Личное сообщение · #7

На Mandrake 9.2 встаёт без проблем.
Дальше с мучениями - нужно ставить "правильные либы", всякие патчи.
Опиши, чего не получается.
Чего то не захотел аттачится:
Follow these steps to fix/patch kylix 3 work:

Step 1
Download the ilink and ilink.so patch provided by Andreas Hausladen here:
ilinkpatchfor more info on the patch go to unvclx.sourceforge.net
To install just go to the download directory and run
./ilinkPatch /home/yourname/kylix

Step 2
Download the latest 3.6 clx patch provided by Andreas Hausladen from unvclx.sourceforge.net or here. Copy or save this file to /tmp folder
Install the patch by executing the following from the shell

tar -jxf k3patches.20040915.tar.bz2
/tmp/k3patches/installpatch

Step 3
Download and install the older compatible glibc libraries for running kylix apps from here. Save or copy it to /tmp.
Install by runing from the shell

rpm -i /tmp/compat-glibc-6.2-2.1.3.2.i386.rpm
Now the patching is complete.... now to run kylix do the following

Step 4
export LD_ASSUME_KERNEL=2.4.21
export LD_LIBRARY_PATH=/path_to_kylix/bin

Step 5
Run/Start kylix via
/usr/local/kylix3/bin/startbcb

Step 6
Open your project and change your projects include directories via the project options by adding
/usr/i386-glibc21-linux/include
/usr/include
as the very first include paths to that your include paths..
this will fix the error so that the correct "time.h" be included.

Step 7
Change your lib paths by adding (preferably in the beginning)
/usr/i386-glibc21-linux/lib and
/usr/lib

Finally:
Open the ThrdDemo (the c++ demo included with Kylix in the examples directory) This sample demonstrates the use of threads and different sort algorithms... (remember step 6+7 for this project).
Compile and run/debug....
Congatulations!!! your have done it!!!

web: forum.sources.ru/index.php?s=6bd56b23df960fa951d6a77d42f3d8ae&showtopic=85741



Ранг: 122.2 (ветеран)
Статус: Участник

Создано: 22 мая 2007 15:47 New!
Цитата · Личное сообщение · #8

у меня на первых шагах скрипта он вылетел. сказал, что либа libgtk что ли или что-то в этом роде не той версии. когда ver >= 1.2.0 - скрип останавливает установку.
я поискал где эта либа есть и нашел, что ее походу дела VMware Tools установили. Вернее скорее всего подменили на более новую. т.е. видимо установка может получиться без VMware Tools, но без них работать на разрешении 640*480 не реально просто.



Ранг: 20.8 (новичок)
Статус: Участник

Создано: 22 мая 2007 15:55 New!
Цитата · Личное сообщение · #9

Вообще странно, более новая это вроде нормально.
Может все-таки она младшей версии?
Я помню там был нужен libstdc++ специальной версии, а вот на графику ни разу не ругался при установке.



Ранг: 122.2 (ветеран)
Статус: Участник

Создано: 22 мая 2007 16:23 New!
Цитата · Личное сообщение · #10

нет именно не больше этой версии. только вот за название библы не поручусь. у меня дома все.

выводиться сообщение типа

библиотека такая то. версия >= 1.2.0. FAIL. и все.



Ранг: 63.1 (постоянный)
Статус: Участник

Создано: 22 мая 2007 17:17 New!
Цитата · Личное сообщение · #11

На RedHat 7.2 вставал нормально, но он сам (RedHat 7.2) полное говно, под Мандрик 9-10 шел нормально,под ALT 2.1 тоже работал, вообще подо все редхэтовские линуксы. Вроде под древние Слэки тоже пер. А под Дэбианы нет.



Ранг: 122.2 (ветеран)
Статус: Участник

Создано: 23 мая 2007 09:33 New!
Цитата · Личное сообщение · #12

все таки действительно нужна более новая библиотека libgtk. а где ее можно взять? и можно ли просто взять и заменить библиотеку на более новую?



Ранг: 20.8 (новичок)
Статус: Участник

Создано: 23 мая 2007 12:13 New!
Цитата · Личное сообщение · #13

Вообще можно поставить, но лучше другой Linux, там может начаться вал - glibc не та и т.д.
Взять - надо в гугле искать. Сам сайт gtk - www.gtk.org, но лучше под свою версию Linux найти.
Рекомендую всё таки ставить на Mandrake 9.2 - 10, сам не раз ставил - всё нормально.



Ранг: 122.2 (ветеран)
Статус: Участник

Создано: 23 мая 2007 12:52 New!
Цитата · Личное сообщение · #14

Ок. Спасибо учту. Только мне надо еще сам Mandrake найти. Инет не халявный. Итак дважды пришлось Ubuntu качнуть.


 eXeL@B —› Софт, инструменты —› Установка Kylix 3 Ent

Видеокурс ВЗЛОМ